Disclaimer

This is MY Viewer, i decide which feature i want to add and which to remove, i share this Viewer to show the world that user base size is not important, i do rate quality by effort, thought and love put into the project, not some rough estimated numbers. I consider feature requests only if i you can name proper valid reasons i can agree on. It is my unpaid time i'm putting into this project, i'm not here to cater to every Joe's desires.

Thursday, July 23, 2015

Black Dragon Viewer - Update 2.4.4.1 "Bugfix Update"

Quick n dirty.


It moves the marketplace listing menu entry to Dragon - Edit and overhauls the layout of the floater, also removes the old menu entry for the merchant outbox.





Changelog:




Changed: Overhauled Marketplace Listing floater layout.
Changed: Moved Marketplace Listings menu entry from detach to its intended place.
Removed: Old Merchant Outbox menu entry.

6 comments:

  1. I hadn't updated in a long while, but when I updated to this version I immediately began to see a couple strange graphical issues.

    First, some mesh items around the grid refuse to rez properly. Instead showing as malformed spheres and faces

    Second, objects with hide/show scripts will, when set to hidden, will be rendered visible when I turn around bringing them out of camera then back into camera again.

    Third, faces with emissive masks do not render properly unless I edit the object, change the alpha setting, then change it back to "emissive". That's all that I've noticed since updating yesterday

    ReplyDelete
    Replies
    1. I couldn't reproduce second and third. First is something i have been seeing for ages now. Some meshes simply don't load until i right click them, basically nothing has changed. #justSLthings

      Delete
  2. The first, mesh not rezzing, isn't all mesh, thankfully. But when I do see it, the object will not rez even when right-clicked. Instead, it remains looking like the default sculpted prim "apple" shape, set to plane. That objects appear as if they were the apple sculpt is new to me, I've never seen that behaviour in mesh before.

    The second, hide/show objects, I was seeing consistently across multiple logins yesterday, but not at all today, so I've no idea. I'll keep an eye out for it.

    For the third, the emissive mask issue, I'm primarily noticing it with an avatar attachment I'm wearing. ONLY when I'm wearing it, and only when I'm wearing it on login. If I wear it after logging in, or it's rezzed in-world, the issue does not appear. The object is mesh and the emissive mask is only on one face, not the entire object.

    ReplyDelete
    Replies
    1. 1. Sounds like a caching problem. You tried a clean install right?

      3. I tried it with my own face, setting it to emissive mask and relogging, it looked as it should both when setting it and after relog.

      Delete
    2. This isn't a caching problem. Everyone I know that is currently using the viewer is experiencing the mesh issue, even with a completely clean install with deleted configuration and cache. Not common in most other viewers.

      Delete
    3. Cleaned my cache, enabled dynamic LoD, disabled Avatar Impostors and toggled Stream Rendering on. Went into a club with lots of meshes. No loading issues at all, all meshes loaded fine and almost instantly.

      Delete