Disclaimer

This is MY Viewer, i decide which feature i want to add and which to remove, i share this Viewer to show the world that user base size is not important, i do rate quality by effort, thought and love put into the project, not some rough estimated numbers. I consider feature requests only if i you can name proper valid reasons i can agree on. It is my unpaid time i'm putting into this project, i'm not here to cater to every Joe's desires.

Thursday, May 9, 2013

2.2.0b (2701)


So... i hope this will be the last Alpha for now...


All i did for this Alpha was merging up the rest of SSB and some additional fixes not even FS has at least not yet visible in their public repository :P

Anyway, SSB works fine now, i can switch outfits as much as i want and they will bake extremly quick, it might take a few seconds sometimes, dont be scared.

I tested both Hippo Hollow which is (Second Life RC BlueSteel 13.05.04.275247) and i tested Hazzlehoff, my favorite emergency place which is using (Second Life Server 13.04.29.274986), both of them were baking my Avatar just fine. I just dont know if its visible to others aswell heh... havnt had anyone checking my Avatar all the time but i didnt hear any complains when i was near people... so... i guess its fine.

I also added the much requested Land Info quick button back (temporarly until i implemented it into the navbar itself), you can either right click and enable it or go to Preferences to do so.

Note: This Alpha was not even intended to contain anything else than JUST merging up the rest of RLVa/SSB. I got plans on what im going to do next, i will explain them in the Beta post.

Snapshots:


Sorry, no super special ones, they will be shown on Beta post :P




And yes, this is real shader based greyscale :P, lights are the interesting part about it, they make stuff around them colorfull again as you can see in the last snapshot.




Changelog:

2.2.0b Alpha

added land info quickbutton to statusbar
merged SSB
fixed alot cases in which avatar wouldnt bake
cleaned up code a bit and tagged some things that needed it

17 comments:

  1. ALL works good now, but quick time:( still glad i can use it:)

    ReplyDelete
    Replies
    1. The plugin fix is considered a possible cause of my increased and now nearly omnipresent FPS drops aswell as texture blurring.

      Delete
  2. Don't really understand if you ar sãying that the fix for the quick time plugin was the cause of lurring and fps drops as i used the last veerion where it works without any of those problems till today and my soulmate stil uses it (last non ssb version) without a single problem as well!
    If you are saying that on this nerw version you are getting fps drops and texture bluring i cant see any of that as well and using it since 3 hours ago without a bvreak or crash and on lots of live shows with lots of other avatars using always full graphics settings but depth of field!

    ReplyDelete
    Replies
    1. Im saying that since i did this release everything i've done could cause this, my FPS drop drastically, everywhere to 5 and less, no matter how many avatars, no matter the place, they will suddenly drop from 40-50 down to 5, lagging and partly freezing extremly for no reason, also my memory overfills extremly quickly starting to really worry me.

      Delete
  3. Ok, i can assure you that i didnt had any of those synthoms!
    Note that i did not delete the roaming folder with the settings of last alpha, just the local and c/program files (X869 one!
    I disabled http textures on graphics textures tab, and set all to ultra but shadows on hig and unchecked depth of field only!
    teleported to at least 9 diff regions, all them with at least 10 or more avatars (Live shows mostly), did notice that textures would take a bit moree to rezz, but almost as good as on the pre ssb 1 that i use witrh http textures enabled!
    Zooming in and out didnt provoque a crash like sometimes when using dr happens with pre ssb 1!
    Textures can get blured after i zoomed out but after zooming in they would rezz again, same with avatars, don't know if that will be intentional from LL code.
    In truth i didnt noticed any big difference from the pre ssb 1 and this last, a bit fast on fps on my system, a bit slow to rezz textures, but no crash for more then 4 hours of intensive use!
    Only thing i notice was that quick time is still not working, but that you already know!
    Rlv was working good (i only dress or undress using open collar mennu and the rlv folder)!
    Steaming as well, unchecked and checked all f1 boxes, no problems at all, sett connection speed to 1500kb.
    So i can't really figure the problem you are having, note i stil have pre ssb version isntaled (i rename the folders like Niran viewerSSb and NiranviewerA so i can use the pre ssb 1 or the SSB by just renaming the 3 folders for the 1 i dont want to use at the moment!)
    So i will revert back to the pre ssb and will wait for your's next, but didnt really find any of the problems you are having!

    ReplyDelete
  4. I am still frustrated by the chat being a little off screen. I cannot find where it is draggable

    see screen:http://i44.tinypic.com/fxb3tf.jpg

    ReplyDelete
    Replies
    1. I marked it red for you
      https://lh6.googleusercontent.com/-yFPGpAl-4-4/UY_FwKfen0I/AAAAAAAAIvY/vBtZ4XoPp6A/s1920/fxb3tf.jpg

      Delete
  5. Not having the problem with FPS dropping, no freezing and textures loading fast too - everything running smoothly for me with this release. My specs, if it helps...

    CPU: Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz (2664.8 MHz)
    Memory: 16380 MB
    OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
    Graphics Card Vendor: NVIDIA Corporation
    Graphics Card: GeForce GTX 670/PCIe/SSE2
    Windows Graphics Driver Version: 9.18.0013.1422
    OpenGL Version: 4.2.0

    ReplyDelete
  6. How did you make it black and white?

    ReplyDelete
    Replies
    1. some shader effects, going to implement them as little extra someday

      Delete
  7. crashes continuously now, some meshes textures are random incorrect and/or distorted, load slowly at times but fast others, but never correct 100%. i have tried adjusting settings, clearing cache and re installing completely.

    specs,

    AMD phenom II 6core @ 3.1GHz
    12GB ddr3 @ 2000MHz
    GPU NVIDIA GeForce GTX 660 Ti 2GB gddr5

    ReplyDelete
  8. I been using this everyday now and havent experienced any real issues. it is stable and performances seems good

    my main 'wish' right now is the little IM bubbles on the lower right would have some sort of indication of a new message. often there will be 5 or 6 of those things, you are chatting with 2 or 3 people in IM, just impossible to know by glancing at them if one has a new message

    ReplyDelete
    Replies
    1. IM or Group icons have a yellow border around them if someone answered in IM or Group.

      Delete
    2. yes... it is somewhat noticeable now you mention it..... but really nothing that jumps out and says I'm New! by just glancing at it :)

      Delete
    3. It is indeed not new, its included since i started my Viewer which makes it a very old change.

      Delete
  9. Using this 1 now as i noticed a very big improvement on using a vehicle to cross sims besides rezing clothes after the deployment of 29may2013 on main grid!
    For some reason when using deferred rendering and tone mapping to linear, all seems to bright, even adjusting and tuning down light effects, so i uncheked the deferred lights box on the machimina bar!
    Still no quick time plugin working but rather then that and the bright compared to the non ssb version, all seems fine!

    ReplyDelete